Commit a8bcc23f authored by Todd Gamblin's avatar Todd Gamblin
Browse files

Spack works with Python 3

- Update version guard in spack script to allow python 3
- Update min required version in the docs
parent 3f21f2b0
......@@ -23,7 +23,8 @@ See the
[Feature Overview](http://spack.readthedocs.io/en/latest/features.html)
for examples and highlights.
To install spack and install your first package:
To install spack and install your first package, make sure you have
Python (2 or 3). Then:
$ git clone https://github.com/llnl/spack.git
$ cd spack/bin
......
......@@ -27,9 +27,9 @@
from __future__ import print_function
import sys
if (sys.version_info[0] > 2) or (sys.version_info[:2] < (2, 6)):
if sys.version_info[:2] < (2, 6):
v_info = sys.version_info[:3]
sys.exit("Spack requires Python 2.6 or 2.7. "
sys.exit("Spack requires Python 2.6 or higher."
"This is Python %d.%d.%d." % v_info)
import os
......
......@@ -40,7 +40,7 @@ for the results of these tests after submitting a PR, we recommend that you run
locally to speed up the review process.
If you take a look in ``$SPACK_ROOT/.travis.yml``, you'll notice that we test
against Python 2.6 and 2.7. We currently perform 3 types of tests:
against Python 2.6, 2.7, and 3.3-3.6. We currently perform 3 types of tests:
^^^^^^^^^^
Unit Tests
......
......@@ -11,7 +11,7 @@ Prerequisites
Spack has the following minimum requirements, which must be installed
before Spack is run:
1. Python 2.6 or 2.7
1. Python 2 (2.6 or 2.7) or 3 (3.3 - 3.6)
2. A C/C++ compiler
3. The ``git`` and ``curl`` commands.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment